Quality Testing

Quality is delighting customers



Iam a beginner in selenium RC. Iam facing some problem in selenium RC.


I tried to open google and type "Software testing" and click on first link.It is working properly in IDE while in Selenium RC clicking first link is failing and displaying error has element not found.


I searched in google but did not get any solution. Please help me to solve this issue.




C.Shree Lakshmi.

Views: 404

Reply to This

Replies to This Discussion

I have also noticed this issue when we use the XPath specified by IDE in RC, some times this error comes. Its better to construct your XPath rather than using the XPath suggested by IDE. I have not come across any issues after this.



Thanks for your reply i constructed my own Xpath for clicking the first link in google and its working properly.


But in our application they have done with frames its not working. Can you please suggest me with some idea. Iam also trying with different ways.



C.Shree Lakshmi.

Hi Lakshmi,

I need some information regarding selenium rc.

Am also using selenium rc am aslo beginner but i need some info.

While opening Junit rc script in selenium rc in /*chrome in command line 

But it opening in firefox only why..


If u dont mine send me the browser list commands while using in selenium rc.


And i also tried while u intimate in discussion but it showing error in selenium IDE also . what prb if u dont mine send me table list formaat that one i tried.






Instead of *chrome you try with *googlechrome. It worked for me.


List of browser supported

Supported browsers include:


inplace of clickandwait u can use selenium.waitforpageload("10000") and install Xpather and firebug plug-ins for ur browser then u can easily identify particular element.


TTWT Magazine





© 2022   Created by Quality Testing.   Powered by

Badges  |  Report an Issue  |  Terms of Service