Quality Testing

Quality is delighting customers

unable to execute sample in ecklispe using selenium rc



 Please help me. i am new to selenium. i am getting error while executing sample google script in ecklispe. please guid me on this

 Please find log file.


14:20:33.841 INFO - Command request: open[/, ] on session null
14:20:33.841 INFO - Got result: ERROR Server Exception: sessionId should not be null; has this session been started yet? on session null
14:20:33.841 INFO - Command request: testComplete[, ] on session null
14:20:33.841 INFO - Got result: OK on session null
14:21:06.653 INFO - Command request: getNewBrowserSession[*iexplore, http://www.google.co.in/] on session null
14:21:06.653 INFO - creating new remote session
14:21:06.653 INFO - Allocated session 294a1aad77bf4b52b33816f8e1912db2 for http://www.google.co.in/, launching...
14:21:06.763 INFO - Launching Embedded Internet Explorer...
14:21:06.778 INFO - Launching Internet Explorer HTA...

Thanks in advance,


Views: 411

Reply to This

Replies to This Discussion

You did not start the Selenium RC server.


so first start selenium RC like "java -jar selenium-server.jar" from command prompt, It will create session.


Execute your program in hte Eclipse.




Hai Sasidhar,

Thanks for your suggestion. i tried with your suggestion and same error was appear. already i done path setting in eclipse (Run-->External tools -->external tools con fig-->program, location as "C:\Program Files\Java\jdk1.6.0_12\bin\java.exe" , arguments as "-jar selenium-server.jar"). Please help me regarding on this.

Thanks and Regards,
It will be easy if you could paste the code you have executed.
please fond error log message

11:56:59.382 INFO - Java: Sun Microsystems Inc. 11.2-b01
11:56:59.382 INFO - OS: Windows XP 5.1 x86
11:56:59.398 INFO - v2.0 [b3], with Core v2.0 [b3]
11:56:59.569 INFO - RemoteWebDriver instances should connect to:
11:56:59.569 INFO - Version Jetty/5.1.x
11:56:59.569 INFO - Started HttpContext[/selenium-server/driver,/selenium-server/driver]
11:56:59.569 INFO - Started HttpContext[/selenium-server,/selenium-server]
11:56:59.569 INFO - Started HttpContext[/,/]
11:56:59.663 INFO - Started org.openqa.jetty.jetty.servlet.ServletHandler@c2ea3f
11:56:59.663 INFO - Started HttpContext[/wd,/wd]
11:56:59.679 INFO - Started SocketListener on
11:56:59.679 INFO - Started org.openqa.jetty.jetty.Server@13f3789
11:57:05.491 INFO - Checking Resource aliases
11:57:05.522 INFO - Command request: getNewBrowserSession[*iehta, http://www.google.com/] on session null
11:57:05.522 INFO - creating new remote session
11:57:05.522 INFO - Allocated session 6c4871bebc30440d8205db014c80f95c for http://www.google.com/, launching...
11:57:05.663 INFO - Launching Embedded Internet Explorer...
11:57:05.679 INFO - Launching Internet Explorer HTA...
import com.thoughtworks.selenium.*;
import java.util.regex.Pattern;

public class Sample extends SeleneseTestCase {
public void setUp() throws Exception {
setUp("http://www.google.com/", "*iehta");
public void testNew() throws Exception {
selenium.type("q", "selenium rc");
assertTrue(selenium.isTextPresent("Results * for selenium rc"));

hey your code is working for me.  you can recheck, do one thing try to execute in firefox first. then try with IE. you might not have browser configuration.




TTWT Magazine





© 2022   Created by Quality Testing.   Powered by

Badges  |  Report an Issue  |  Terms of Service