Quality Testing

Quality is delighting customers

Response Codes are Ok, but Error Log is displayed

OpenSTA 1.4.4:
1) Recorded the script with an intranet application.
2) Executed the Test with 75 virtual users. Test Error Log was not displayed. Verified the HTTP Data List and it had 2 set of response codes: 200 and 304
3) Again executed the Test with 95 virtual users. Verified the HTTP Data List and it had the same 2 set of response codes: 200 and 304. I came to know that these response codes are ok. However Test Error Log was displayed in this scenario and it had following 3 set of messages:
i) ERROR 10060
ii) ERROR 10038
iii) ERROR for VU 1-32: REQUEST(12): GET /images/heading-bg.jpg HTTP/1.1 failed with error An operation was attempted on something that is not a socket.

Since I am new to any load testing tool, I am not clear about the results displayed. Can I conclude that the application either will support up to 95 virtual users since the response codes are 200 and 304 or will not support 95 virtual users since it displayed the Test Error Log?

Views: 161

Reply to This

Replies to This Discussion

hi,

 

                     This is kripa.. Regardsing yo error. Yo shouldn't get the status code 304. It means that it is not able to Open an IP socket connection to that IP address. As well can also be due to it is not able to Write an HTTP data stream through that socket. usually yo shldnt get this error. It indicates defective programming by us or the developers of the Web server software.If the Web server implements the HTTP protocol properly, it should never send an 304 status code back to us. As well the error 10060 is comin due to connection timed out. Please do check the codes. Pls dont conclude that it supports because there is no proper communication happening to the web server. so you ll not be able to get the proper response time.

Thanks a lot Kripa for your reply.

You have mentioned that 304 response is due to defective programming. I have not written the scripts. I just recorded and played back. Please suggest me, what should I talk with the developers to avoid this response code.

Hi Kripa,

Please refer this: http://www.sqaforums.com/showflat.php?Cat=0&Board=UBB36&Num...

 

It says that 304 response code is not a problem.

 

RSS

TTWT Magazine


Advertisement

Advertisement

Advertisement

Advertisement

© 2021   Created by Quality Testing.   Powered by

Badges  |  Report an Issue  |  Terms of Service